Cómo solucionar el error: No se pudo bloquear /var/lib/dpkg/lock

Cómo solucionar el error: No se pudo bloquear /var/lib/dpkg/lock. Cuando hay una actualización interrumpida y los paquetes de actualización se corrompen sucede este error, lo que mantiene ocupado los procesos de actualización en un ciclo infinito. En este tutorial te enseñamos una sencilla forma de cómo solucionarlo.

  • Abre un terminal e introduce este comando para matar el proceso de actualización pendiente:
sudo fuser -vki  /var/lib/dpkg/lock
  • Todo seguido pon este comando para eliminar el fichero que contiene los datos de la actualización errónea:
sudo rm -f /var/lib/dpkg/lock
  • A continuación introduce este comando para que se reparen los paquetes de actualización que se hayan descargado:
sudo dpkg --configure –a
  • Perfecto, ahora ya puedes proceder a la actualización, aunque es recomendable que al terminar la actualización y antes de iniciar la próxima ejecutemos el siguiente comando para eliminar y reparar paquetes rotos:
sudo apt-get autoremove

Hasta aquí el tutorial de “Cómo solucionar el error: No se pudo bloquear /var/lib/dpkg/lock

Puedes ver más artículos desde el inicio.

Si estás interesad@ en comprar componentes informáticos, te dejamos un enlace para que puedas montar tu PC gamer a precios asequibles, click aquí

Artículos recientes

Relacionados

Recibe las novedades